«•» GeoSharing Worlds No.1 Satellite Forum «•»

This is a sample guest message. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

VU+ Addons, Tools and Other files

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
e2m3u2bouquet-enigma2-plugin

whats new:


Code:​
-Fix issue where new providers couldn't be added
-When providers bouquet is downloaded (-b or -bd option) now uses full
service references
instead of just the epg relevant part in case it's used for picon naming
-Better multi provider handler e.g. if there is an issue with one provider it
won't stop the script processing others
-If vod categories are out of order in the playlist group together
-Fix file naming issues with non alphanumeric characters
-Much faster when using an override file :)
-Don't retry failed picon downloads
-Option to add placeholder channel in override file (to control channel numbering)
-Allow channels to be moved between categories, use categoryOverride in the override file
-All custom categories, use customCategory="true" in the override file
-Add provider managed update support
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
Plugin VWeather3

Quote:
First: Many thanks to @NaseDC, @ Nathanael2316, @schomi, @Maggy and @ gordon55 for their time, testing and the many hints when creating the plugin.

VWeather3 is a plugin that provides a compatible converter to the no longer functioning Yahoo weather for free use in skins.
Currently the plugin supports two alternative weather services.
1. OpenWeatherMap
2nd darksky

The two services proved to be very reliable during the tests. Difference to the previous Yahoo weather.
OpenWeatherMap only delivers 5 days of forecast.
darksky provides only 8 days of forecast.
Since mWn does not have freely available weather APIs anymore and these are also limited by the number of calls, unfortunately, no user key can be deposited here for everyone. So get hold of one
Service of your choice a free API KEY.

Link for OpenWeatherMap -> home.openweathermap.org/users/sign_up
Link for darksky -> darksky.net/dev/register

Currently, the plugin supports a number of skins, which should be re-supplied with weather data after successful plugin configuration.


Directly supported skins:

Chameleon
iFlatFHD
linearFHD
BundesligaFHD
insaneFHD
CerxFHD
Vu_HD_1080P
StyleFHD
AtileHD
MuteSpectator


Installation:

Make an image backup if something goes wrong!
Installs the attached enigma2-plugin-extensions-VWeather3_1.0-R9_all.ipk.
Restart the box and start under extensions VWeather3 and make the settings described below.
Closing the plugin with "Red" automatically creates a suitable converter for the supported skins
Exit exits the plugin without saving the settings or creating the converter.


Settings in the plugin:

General
Update in minutes: time interval by the converter updating the data
Country code: National language in which possible weather texts are to be returned by the provider.
Units: units for temperatures, wind speeds ..
Number of decimal places: Number of decimal places for temperatures

Weather service
Provider: Select OpenWeatherMap or darksky
Settings when selecting OpenWeatherMap
OpenWeatherMap API Key: Your API Key
Localization: Select location or postal code
Place: your place
Postcode: Your postal code
I recommend doing the place to choose, because in the postcode always the next larger city is displayed. Use postcode if you live in a place that has several times and you may get wrong dates.

Settings when selecting darksky
darksky API-Key: Your API-Key
Latitude: Latitude
Longitude: Longitude
lat, lon for your place of residence is best to look for maps.
Show weather warnings as popup: Select yes / no
The weather service also provides local weather warnings. If you set this to yes, an info window is displayed as soon as the converter finds a warning in the data.

system
write logfile: selection yes / no
The plugin will write a logfile for support purposes under / usr / lib / enigma2 / python / Plugins / Extensions / VWeather3
The converter itself writes a logfile under /tmp/VWeather3.log
If the weather works fine with you, just switch off.


What do I do if my skin is not directly supported:

If the skin you are using is not yet supported, the plugin still creates a converter under / usr / lib / enigma2 / python / Components / Converter named VWeather3.
Ask your Skin or Skinpartersteller if the converter used in it is compatible with the old VWeater.py or VWeather2.py and what its name is in the Skin.
If the old converter is compatible, it is sufficient to rename the created converter VWeather3.py as the call name in the skin.
Alternatively, all calls for the weather in the skin in VWeather3 can be renamed. (Please be careful, incorrect entries in the skin can lead to a boot loop)
Restart box and again the weather should work again.
But I assume that the affected skins will soon get an update in which the new converter is already installed.


Note for Skinner:

The "WeatherInfo" Dictionary from VWeather or VWeather2 became "provider" - display of the weather provider and "alerts" - display of severe weather warnings (only supplied by darksky
enigma2-plugin-extensions-VWeather3_1.0-R9_all.zip (16.65KB)
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
RussianMediaPark 16.8

To work in the image of VTI, an item has been added to the menu of the plugin - Scrolling text for Openple. That is, if you are in VTI, keep this item disabled (by default it is disabled already). And for other images, you can turn it on if it does not slow down at the same time.

- Fix date display in full HD skin
- Fix in HDKinoteatr.Com, The-Cinema.Club resources
- Added a new playlist for those who do not show Soviet. RF, where about 2000 movies of the Soviet period
Soviet movies


enigma2-plugin-extensions-russianmediapark_16.8_all.rar (3.63MB)

enigma2-plugin-extensions-russianmediapark_16.8_armhf.rar (2.33MB)
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
NeoBoot by gutosie

Supported boxes:
[*]et8500[*]SF4008[*]Ultimo4k[*]Ultimo[*]Zero[*]OSmini[*]Formuler F1[*]MBmini[*]Solo4k[*]Uno[*]Solo[*]Duo4k[*]Formuler F3[*]atemio6000[*]Uno 4K[*]Duo2[*]Solose-v2[*]Zgemma h7S[*]MBmini[*]Miraclebox Micro[*]Uno4kSE[*]Duo[*]Solose[*]Octagon Sf8008[*]Miraclebox Ultra[*]Zero 4K[*]Solo2[*]Zgemma H9S

The first neoboot installation
Run the following command in the supported tuner terminal:



Another way to install, if the curl tool does not work correctly, then try the command:

opkg update

cd / tmp


chmod 0755 /tmp/iNB.sh

/tmp/iNB.sh

NeoBoot-7.07_all.IPK.zip (1.89MB)
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
NeoBoot v.7.12

-Turkish language added


Supported boxes:
Ultimo4k : 7444s
Solo4k : 7376
Zero 4K : 72604
Duo4k : 7278 #BCM7278
Uno 4K : 7252s
Uno4kSE : 7252s
Ultimo : 7405(with 3D)
Uno : 7405(with 3D)
Duo : 7335
Duo2 : 7424
Zero : 7362
Solo : 7325
Solose : 7241
Solose-v2 : 7241
Solo2 : 7356
Formuler F1 : bcm7356
Formuler F3 : 7362
Miraclebox MBmini : bcm7358
Miraclebox Micro : bcm7362
Miraclebox Ultra : bcm7424
Octagon Sf8008 : 3798mv200
Zgemma h7S : bcm7251s
Zgemma H9S :
AX HD60 4K : hi3798mv200 root@ax60:~# cat /etc/hostname : ax60
OSmini : BCM7362
atemio6000 : bcm7362

enigma2-plugin-extensions-neoboot_7.12_all.ipk.zip (1.90MB)
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
RussianMediaPark 17.1

Version 17.1

  • errors made in version 17.0 have been fixed
  • the series is fixed in the Filmix.Co resources
  • movie descriptions are set in the ZfilmHD.Org resources
  • The content resource is repaired in Mediabox.Uz
  • HDKinoteatr.Com has been fixed the addition to favorites
  • In the ZFilmHD.Org resource, the addition to favorites has been improved
  • Empty links are set in Clubser.info resources.


enigma2-plugin-extensions-russianmediapark_17.1_all.ipk.zip (3.67MB)
 

pentafull

File Master
File Master
Joined
Dec 18, 2018
Messages
439
Reaction score
13
Points
18
Pure2 Plugin-FNC

yify-FNC Plugin


This is the world's first torrent player on E2 - ever! It streams 3D/720p/1080p official YIFY torrents.

For PurE2 users only.

Use at your own risk!
We recommend one uses this plugin ONLY with some VPN plugin!!!!! We can not stress this strongly enough! In some countries it won't even work at all without it! You have been warned!!!


=================The technical bits=================


yify-FNC is a torrent player which parses torrents from various torrent sites, but the main source is an official YTS.AM. What you see on yts.am you will be able to see in plugin as well.

For other levels of quality like: 720p-h.265 / 1080p-h.265 / 4K, the plugin uses third party sources like: ettv, torlock, torrentfunk, yourbittorrent, piraterio, torrentgalaxy, toros, rarbg...

Installation:
It's simple, you can either
  1. wait for an image update, then you will get yify-FNC via feeds (=> MENU > Plugins > green button > Extensions), or
  2. if you don't want to wait, install as ipk file:

  • first make sure you have the latest image update
  • FTP .ipk file to /home/root/ folder
  • in telnet give the following command: opkg install *.ipk (where * = the name of the file)
  • restart PurE2
Using the plugin:
There are plenty of options/features inside, but I will not explain all of them, only a few important ones.
To get the many options we just mentioned => start the plugin and press the Menu button.

  • download path - here one can choose the path for downloading but do not use FAT32 devices/partitions - use EXT4 or NTFS formatted devices/partitions instead!
    (HDD/SSD and NAS servers are better solutions to download to; on the other hand, USB sticks are OK but not that great, and again - not formatted in FAT32!)

  • buffer size (to be determined before playing a file) - here you can change pre-download size - sometimes 3% is enough to play without stuttering, sometime 5, 8 or even greater % is needed... it depends on peers, your network, movie quality, etc. etc.
  • If you are not sure what you are doing... leave all other torrent options as you find them...
  • all the other options not directly connected with torrents - feel free to change at will: for instance, auto-subtitle on/off, subtitle language, plugin appearance, translation, etc. etc.
Please note:

  1. If your provider blocks access to YTS.AM, there is a possibility to change YTS domain to some mirror domain, eg. ytss.unblocked.is (BUT! It is still safer to use VPN!!!)
  2. When you start setting up the plugin, as a standard user you will not be able to see all levels of movie quality/resolution - but only 720p!

Thanks FrancHR


enigma2-plugin-extensions-yify-fnc_3.0-r1_aarch64.ipk.rar (724.37KB)
enigma2-plugin-extensions-yify-fnc_3.0-r1_cortexa15hf-neon-vfpv4.ipk.rar (851.96KB)

enigma2-plugin-extensions-yify-fnc_3.0-r1_mips32el.ipk.rar (706.39KB)
 
Top